January 23, 2018, 11:37:27 AM

collapse

* 'Like' And 'Follow' Us!

* Sero 7 & 8 Market

Author Topic: Re: Help my Sero 7 pro stopped Charging.  (Read 1682 times)

Offline LuckyMe

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2497
  • Popularity: 194
    • View Profile
Re: Help my Sero 7 pro stopped Charging.
« on: July 28, 2015, 12:04:55 PM »
I split this out from another topic so instructions for repair can be located later down the road... 







oh...... :(   my first thought is leave it for a few hours.. see what happens then.
« Last Edit: August 03, 2015, 02:12:13 PM by LuckyMe »



A nandroid is a man's best friendainol Venus-Firomi v3.2
S7P DoPa Lollipop 5.1
Vidaa Pad 8 Oma V1.1

Offline rshalev

  • Jr. Member
  • **
  • Posts: 77
  • Popularity: 1
    • View Profile
Help my Sero 7 pro stopped charging.
« Reply #1 on: July 28, 2015, 03:34:04 PM »

Thanks Laura,
I did, left it like this overnight - Nothing. It won't turn on since the battery is probably empty...

Tried to wiggle the USB plug to see if there was a lose contact, no luck, tried different charging adapters and cords, still the same...

Open to any suggestions???

Thanks
Rami
« Last Edit: August 03, 2015, 02:11:55 PM by LuckyMe »

Offline LuckyMe

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2497
  • Popularity: 194
    • View Profile
Re: Re: Help my Sero 7 pro stopped working
« Reply #2 on: July 28, 2015, 07:32:20 PM »
Well,  it's a long shot.  I have this issue with my power button,  it's displaced or something under the button.  The button is no longer raised as high as it should be.  So when I press it,  it doesn't always press the actual button under the exterior button.  So I have to kind of press the button more to the side then directly on it.  It's hit or miss. One day I couldn't wake it up at all.   So,  maybe press your button in an un conventional way a few times.  Maybe you'll get lucky.  Maybe. 

On a more tradition troubleshooting idea.. it could be the wire came off the power charging port internally.  As the charging port has been an issue with some of these tablets from day one.  You would have to open the tablet to confirm that. But usually the problem starts with a loose port.

Although not loose,  there maybe something here to help.

http://sero7forum.com/sero-7-help/loose-charging-port/msg8209/#msg8209

And on a completely other idea.. the battery wire came off.  I read it happened to someone once. But that is pretty rare. I'd even say very rare.

A nandroid is a man's best friendainol Venus-Firomi v3.2
S7P DoPa Lollipop 5.1
Vidaa Pad 8 Oma V1.1

Offline rshalev

  • Jr. Member
  • **
  • Posts: 77
  • Popularity: 1
    • View Profile
Re: Re: Help my Sero 7 pro stopped working
« Reply #3 on: July 31, 2015, 05:12:31 PM »
Hello Laura, Hello Terry,
Thank you both very much for your inputs..
I totally agree with Terry, I did quite a lot of soldering of electronic projects for my sons and then for my grandkids (as an electronic technician and later as an electronic engineer). I would not dare to touch these new computer controlled soldering devices of pc boards or tablets - one needs special microscopes and tools for this.

I'm glad to report that I solved my - Tablet Not charging issue
1. My power adapter and the USB charging cable were OK since it displayed the thunderbolt symbol and the connection buy no charging.
2. Removed the back cover of the tablet (thanks Laura for the links, I had the tools I needed since I've done this before).
3. I tried to see if the charging port was lose or one of the pins not making contact. To do this, I identified the + and the - pints of the port on the mother board (see picture # 1).
3. Connected the charging power adapter to power and measured the voltage (using a digital multimeter) between the (+) and the (-) poles shown in picture # 1. I got a reading of 5VDC. This indicates that the charging port is OK.
4. Now, I measured the voltage across the battery's large white connector across the (+) and the (-) - See picture #2.. The reading there was 3.7 VDC - which is the correct voltage since the battery is 3.7VDCS. 
5. After the above, I removed the battery's connector (the bottom part with all the wires (2 red on the right and 2 black ones the left). Measured the voltage in the connector on the battery side. It turned out that the Minus polarity was not getting through - the pin inside was loose and was not making contact with the connector from the battery. I pulled it out a bit, squeezed it with a pair of pliers and reinserted the connector from the battery. And Walla - the 3.7VDC is present on the battery side as well and the Tablet's screen started to show charging. Problem solved..

I received A LOT of help with my S7P tablet from all the wonderful people on this site. I hope that my experience with this issue and the solution to it will help some of you as well.

I tried to attach the pictures but the system did not allow me to do so???
Not sure why??
Rami

Offline LuckyMe

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2497
  • Popularity: 194
    • View Profile
Re: Re: Help my Sero 7 pro stopped working
« Reply #4 on: August 01, 2015, 07:13:18 PM »
Awesome!! Thanks for sharing all the details!  I hope others give you a thumbs up. I don't have the authority as a moderator to give them.


As for pictures,  they must be uploaded to a site first,  then the link posted. I use photobucket.

Glad you have that tablet charging again.

A nandroid is a man's best friendainol Venus-Firomi v3.2
S7P DoPa Lollipop 5.1
Vidaa Pad 8 Oma V1.1

Offline rshalev

  • Jr. Member
  • **
  • Posts: 77
  • Popularity: 1
    • View Profile
Re: Re: Help my Sero 7 pro stopped working
« Reply #5 on: August 02, 2015, 04:30:42 PM »
Thanks Laura,
I am really not concerned about that (:

Coming back for a minute to the Clocking issue discussed earlier.. I experimented with the available speeds as you suggested. Went all the way up to 1.5GHz. The tablet became very sluggish and and the back of the unit where the processor is became quite hot. Went back to 1.4 GHz and it seems to be responding well now. 

I did not change the GPU speed, left it at 448MHz. Not sure where Shneor got the 574MHz from since the options are only 448 & 520?

Thanks Laura
Rami