January 22, 2018, 11:59:50 AM

collapse

* 'Like' And 'Follow' Us!

* Sero 7 & 8 Market

Author Topic: HELP! - Sero 7 Pro is 'Unknown USB Device' to all my PCs  (Read 1721 times)

Offline GhostOfRasputin

  • Newbie
  • *
  • Posts: 1
  • Popularity: 0
    • View Profile
HELP! - Sero 7 Pro is 'Unknown USB Device' to all my PCs
« on: March 16, 2016, 07:37:17 AM »
I just received a ‘refurb’ to replace my crushed Sero 7 Pro.

It does not connect for file transfer like my last Sero 7 Pro did.  Both my Windows 7 and Windows 10 PCs identify it as ‘Unknown USB device (Device Descriptor Request Failed)’.

I contacted Hisense, but they were no help.

I've tried
-toggling between MTP and PTP modes on the tablet, and
-activated developer mode to try toggling USB debugging if that would help.
-From device manager I tried both uninstalling the device and letting let windows search for a better driver.

I spent a couple hours googling, but found nothing else helpful.  I could return it, but the source is out of stock, so I am really trying to make this a keeper.  It came with Jellybean 4.2.1.  I will add that it is not a proper refurb, since it still has a few pictures and a video of the boy who owned it.  I would really appreciate any suggestions.
« Last Edit: March 16, 2016, 07:40:12 AM by GhostOfRasputin »



Offline shneor

  • Sr. Member
  • ****
  • Posts: 368
  • Popularity: 16
    • View Profile
Re: HELP! - Sero 7 Pro is 'Unknown USB Device' to all my PCs
« Reply #1 on: March 18, 2016, 01:31:48 PM »
This may be a long shot, but are you using a firewall? If so, it's possible that you may have to specifically allow communication with your Sero.

Shneor
Shneor
Sero 7 Pro, Dopa 5.1

Offline LuckyMe

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2497
  • Popularity: 194
    • View Profile
Re: HELP! - Sero 7 Pro is 'Unknown USB Device' to all my PCs
« Reply #2 on: March 21, 2016, 09:36:39 AM »
Hi,  welcome to the forum.  The sero isn't so picky with cords when you're charging,  but very picky sometimes with data transfer.  Be sure your data cable is an official hisense cable.  If thats not possible,  try another. 

I know you said you tried it already,  but after un installing the drivers did you do a shutdown and restart of the PC?  That's an important part,  I have found. 

And it won't help this issue,  but you should do a factory reset on that tablet.  Any remaining data from someone else after that means something is wrong with that tablet….. And , IMO,  no refurbishment was done to that tablet. 

A nandroid is a man's best friendainol Venus-Firomi v3.2
S7P DoPa Lollipop 5.1
Vidaa Pad 8 Oma V1.1